Difference between revisions of "VMware"

From Manjaro Linux
Jump to: navigation, search
m (Advice, Tips, and Tricks: rename to Resources)
(IMPORTANT: added link)
Line 5: Line 5:
 
=== '''IMPORTANT''' ===
 
=== '''IMPORTANT''' ===
 
{{Warning|<p>Running VMware on Manjaro host is unsupported and may cease function after updates.</p>
 
{{Warning|<p>Running VMware on Manjaro host is unsupported and may cease function after updates.</p>
<p>'''Please see the link to VMware support page below'''.</p>}}
+
<p>'''Read the [https://kb.vmware.com/s/article/2129859 VMware support] article'''.</p>}}
  
 
== Install vmware-workstation ==
 
== Install vmware-workstation ==

Revision as of 11:49, 3 November 2019


Installing VMWare Workstation on Manjaro

IMPORTANT

Warning:

Running VMware on Manjaro host is unsupported and may cease function after updates.

Read the VMware support article.

Install vmware-workstation

The AUR package vmware-workstation will install VMWare Workstation and the dkms modules needed to run it.

It can be installed with:

 pamac build vmware-workstation

After installing, either reboot, or load the required modules

 sudo modprobe -a vmw_vmci vmmon


Start and enable services

There are three services that can be optionally be enabled:

  • vmware-networks.service: Provides network access inside VMs, most people will want this enabled
  • vmware-usbarbitrator.service: Allows USB devices to be connected inside VMs
  • vmware-hostd.service: Enables sharing of VMs on the network

To start and enable these services use:

 sudo systemctl enable --now vmware-networks.service
 sudo systemctl enable --now vmware-usbarbitrator.service
 sudo systemctl enable --now vmware-hostd.service

Installing Manjaro under VMWare

There are no special requirements to installing Manjaro on VMWare. open-vmware-tools is pre-installed. It should "just work"


Copy and Paste

If copy and paste does not work, you may need to install gtkmm3 and re-boot. vmware-user-suid-wrapper depends on gtkmm, but it's not a required dependency of the package. See: https://bugs.archlinux.org/task/43159

Resources